Skip to content

Disallowed WP-CLI commands

Though the CLI commands listed below are disallowed, some of the processes they perform can be achieved by writing a custom WP-CLI command. For example, though several db WP-CLI commands are disallowed, a custom WP-CLI command could run a function that leverages $wpdb->query().

  • admin: *
  • cli: alias, cache, check-update, cmd-dump, completions, has-command, info, param-dump, update
  • comment: generate
  • config: *
  • core: check-update, download, install, is-installed, multisite-convert, multisite-install, update, update-db, verify-checksums
  • cron-control: *
  • cron-control-fixer: *
  • db: check, clean, cli, create, drop, export, import, optimize, repair, reset, search, tables
    • wp db query is allowed, but defaults to read-only. For write operations, wp db query must be passed with --read-write. Queries that include DROPTRUNCATE or CREATE cannot be executed.
  • dist-archive: *
  • eval: *
  • eval-file: *
  • find: *
  • i18n: *
  • import: *
  • jetpack:
    • authorize-user: *
    • block: *
    • call_api: *
    • options: delete, update
    • partner-provision: *
    • partner-cancel: *
    • protect: *
    • reset: options
    • scaffold: *
    • upload-ssh-creds: *
  • jetpack-start: *
  • jetpack-start-provision: *
  • language:
    • core: install, uninstall, update
    • plugin: install, uninstall, update
    • theme: install, uninstall, update

Disallowed VIP MU plugin and WP-CLI commands

Some built-in and VIP MU plugin WP-CLI commands (and/or subcommands) are blocked from use on the VIP Platform to ensure the safety of a site.

  • media: import, regenerate
  • package: *
  • plugin: delete, install, update
  • post: edit, generate
  • profile: *
  • scaffold: *
  • server: *
  • shell: *
  • site: empty
  • term: generate
  • theme: delete, install, update
  • user: generate, import-csv
  • vaultpress: *
  • vipsupport: *
  • vip:
    • cmd-scheduler: *
    • files: *
    • fixers: *
    • migration: *
    • plugin: *
    • two-factor: *
    • utf8mb4: *

Disallowed global parameters

  • --exec
  • --http
  • --path
  • --require
  • --ssh

Last updated: December 26, 2023

Relevant to

  • WordPress